Hydroponics Online Home Home Store Blog Forums FAQs Lesson Plans Pictures

Go Back   Hydroponics Forums Discussions > Hydroponics Discussion Forums > Hydroponics

Wierd spots on chili leaves :(


Reply
 
Thread Tools Display Modes
  #1  
Old 07-15-2009, 06:55 PM
Stumbo Stumbo is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Default Wierd spots on chili leaves :(

All the leaves on both my chili plants have these spots of brown and discoloration, is this a deficiency, or is it too much of something?

Attached Thumbnails
Click image for larger version

Name:	New Image.jpg
Views:	601
Size:	14.0 KB
ID:	60  
Reply With Quote
  #2  
Old 07-15-2009, 11:33 PM
Stumbo Stumbo is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Default

After a bit of research i think I found my problem. I am using Ammonium sulfate in my mix. Apparantly because ammonium is absorbed so rapidly by plants, its creates a toxic situation.
Reply With Quote
  #3  
Old 07-16-2009, 09:16 PM
HydroACR HydroACR is offline
Junior Member
 
Join Date: Feb 2009
Posts: 25
Default

thanks for the info, can they recover if you change the nutrient solution?
Reply With Quote
  #4  
Old 07-17-2009, 04:07 PM
Stumbo Stumbo is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Default

Not sure, guess well find out :P

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.